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Introduction

What is R?

R is a high-level computer language and environment for statistics and
graphics
R was initially written by Ross Ihaka and Robert Gentleman at the
Department of Statistics of the University of Auckland in 1993 (hence the
name)
R is the result of a collaborative effort with contributions from all over the
world
Current version: R version 3.6.3 (2020-02-29)
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Introduction

Why R?

R is FREE
Runs on a variety of platforms, Windows, MacOS, and Linux
R is open source:
Anyone can add new tools in it that can then be used by everyone
Currently, the CRAN (the Comprehensive R Archive Network) package
repository features about 15,000 available packages
Powerful packages for Machine Learning and Data Science: caret, gbm,
ggplot2, etc.

Chen Zhu (CAU)

Introduction to R

3 / 52

R Basics

Installing R and RStudio

Install R from CRAN: Go to the CRAN website
(https://cran.r-project.org/) and download the version of R for your
operating system
Install RStudio Desktop (FREE): Go to the RStudio website
(https://www.rstudio.com/products/rstudio/download/) and
download the free version of RStudio Desktop that is appropriate for your
operating system
NOTE: Make sure you have installed R first
While R itself is a programming language with a very basic
command-line interface, RStudio allows you to modify, visualize, and run
your R code in a unified, user-friendly interface
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R Basics
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Check
spelling

Render
output

Choose
output
format

Jump to Jump
previous to next
chunk
chunk

Write Code
Navigate
tabs

Compile as
notebook

R Support
Run
selected
code

Cursors of
Re-run
shared users previous code

Source with or Show file
without Echo outline

Multiple cursors/column selection
with Alt + mouse drag.

Load
workspace

Pro Features

History of past
commands to
run/copy

Save
workspace

Display .RPres slideshows
File > New File >
R Presentation

T H J

H J

Delete all
saved objects

Tab completion to finish
function names, file paths,
arguments, and more.

PROJECT SYSTEM

Display objects
as list or grid

File > New Project
RStudio saves the call history,
workspace, and working
directory associated with a
project. It reloads each when
you re-open a project.

Name of
current project
Displays saved objects by
type with short description

View in data View function
viewer
source code

Multi-language code
snippets to quickly use
common blocks of code.
Change file type

Jump to function in file

Working
Maximize,
Directory
minimize panes
Press ! to see
Drag pane
command history boundaries

Debug Mode
Open with debug(), browser(), or a breakpoint. RStudio will open the
debugger mode when it encounters a breakpoint while executing code.

Launch debugger
mode from origin
of error

Open traceback to examine
the functions that R called
before the error occurred

Turn on at Tools > Project Options > Git/SVN
Push/Pull View
Stage Show file Commit
diﬀ
staged files to remote History
files:

•
•
•
•
•

R
?

Added
Deleted
Modified
Renamed Open shell to
Untracked type commands

Package Writing
Resume Quit debug
execution mode

File > New Project >
New Directory > R Package
Turn project into package,
Enable roxygen documentation with
Tools > Project Options > Build Tools
Roxygen guide at
Help > Roxygen Quick Reference

Export Delete
plot
plot

Delete
all plots

GUI Package manager lists every installed package

Install
Update Create reproducible package
Packages Packages library for your project

Version Control with Git or SVN

M

Step through Step into and
code one line out of functions
at a time
to run

Change
directory

A File browser keyed to your working directory.
Click on file or directory name to open.

D

Highlighted
line shows
where
execution has
paused

Upload Delete Rename
file
file
file

Path to displayed directory

A

Click next to
line number to
add/remove a
breakpoint.

RStudio opens plots in a dedicated Plots pane

Navigate
Open in
recent plots window
Create
folder

Start new R Session
in current project
Close R
Session in
project
Select
R Version

Search inside
environment

Choose environment to display from
list of parent environments

Syntax highlighting based
on your file's extension

Choose
Publish to
Manage
location to shinyapps.io publish
view app or server
accounts

Examine variables Select function
in executing
in traceback to
environment
debug

Share Project
Active shared
with Collaborators collaborators

Code diagnostics that appear in the margin.
Hover over diagnostic symbols for details.

Run this and Run this
all previous code chunk
code chunks

RStudio recognizes that files named app.R,
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Installing and loading packages

# Install packages (e.g. ggplot2 for plotting):
install.packages("ggplot2")
# Load packages:
library(ggplot2)
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R Basics

Getting Help

Google
StackOverflow
bing.com
Getting help during an R session:
?ggplot2
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R Basics

Comments in code

To use comments in your code, use the # symbol to ignore the rest of the line:
# This is a comment and R will ignore this.
# pi is an object so R will print its value.
pi
[1] 3.141593
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R Basics

Case-sensitivity

R is case-sensitive
A variable named x is not the same as a variable named X
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R Basics

Assignment and variables

In R, we use <- to assign something from the right side of the arrow to the left:
# For example x <- 5 assigns the value 5 to the variable x:
x <- 5

You can use almost anything as a variable name as long as it starts with a letter
and only contains alphanumeric characters and _ or .
Naming and notation in R: http://adv-r.had.co.nz/Style.html
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R Basics

Data types

logical - Boolean values, e.g., TRUE or FALSE
numeric - decimal (floating point) values, e.g., 2.6 or 1.0
integer - whole numbers, e.g., 3, or -1
character - strings, e.g., ‘apple’
To see the data type of an object just use typeof():
one_to_five <- 1:5
typeof(one_to_five)
# Returns `integer` which is a numeric type
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R Basics

Data objects

You can store these data types into objects or collections:
vector - a 1-dimensional array of the same type
matrix - a 2-dimensional array of the same type
array - an n-dimensional version of a matrix
dataframe - a 2-dimensional array where each column is of the same type
list - a container that can have anything else (including another list) as an
element
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R Basics

Examples of objects

# A value
x <- 12
x
## [1] 12

# An expression
y <- sqrt(2)
y
## [1] 1.414
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R Basics

Examples of objects (cont.)
# A vector
z <- c(2, 4, 6)
z
## [1] 2 4 6
m <- c("c", "a", "u")
m
## [1] "c" "a" "u"
n <- rep(1:3, 2)
n
## [1] 1 2 3 1 2 3
n[3]

# 3rd element of n

## [1] 3
Chen Zhu (CAU)
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R Basics

Examples of objects (cont.)
# A matrix
b <- matrix(c(5,0,6,1,3,5,9,5,7,1,5,3),nrow=3,ncol=4, byrow=TRUE,
dimnames = list(rows=c("r.1", "r.2", "r.3"),
cols=c("c.1", "c.2", "c.3", "c.4")))
b
##
cols
## rows c.1 c.2 c.3 c.4
##
r.1
5
0
6
1
##
r.2
3
5
9
5
##
r.3
7
1
5
3
b[1,3] # 1st row, 3rd column
## [1] 6
# dimension of matrix b
dim(b)
## [1] 3 4
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Data Structures

Data Frames

A data frame is a list of variables of the same length with unique row names
Data frames are produced with data.frame()
Data frames can have names for the columns with either names() or
colnames()
Data frame can have row names with rownames(), must be unique
Note: Both matrix and data frame are 2 dimensional data structure. While
matrix is homogeneous (i.e., same type elements, numeric/logical/character),
data frame is not
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Data Structures

Data Frames (cont.)

Create and give names to a data frame:
x<-matrix(1:4,nrow=2)
y<-c("a", "b")
df<-data.frame(x = x, y = y)
df
##
x.1 x.2 y
## 1
1
3 a
## 2
2
4 b
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Data Structures

Data Frames (cont.)

To change the column names and row names we can do so as follows:
rownames(df)<-c("one", "two")
colnames(df)<-c("X1 variable", "X2 variable", "Y variable")
df
##
X1 variable X2 variable Y variable
## one
1
3
a
## two
2
4
b
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Data Structures

Data Frames (cont.)

# An online example:
library(foreign)
library(MASS)
cdata <- read.table("http://zhuchen.org.cn/wp-content/uploads/2020/03/crimedata.txt"

# check if data.frame:
is.data.frame(cdata)
## [1] TRUE
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Data Structures

Data Frames (cont.)

# view the first few rows of the data
head(cdata)
##
##
##
##
##
##
##

county year
1
1
81
2
1
82
3
1
83
4
1
84
5
1
85
6
1
86

crmrte
0.0398849
0.0383449
0.0303048
0.0347259
0.0365730
0.0347524
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prbarr
0.289696
0.338111
0.330449
0.362525
0.325395
0.326062

prbconv
0.402062
0.433005
0.525703
0.604706
0.578723
0.512324

prbpris avgsen
0.472222
5.61
0.506993
5.59
0.479705
5.80
0.520104
6.89
0.497059
6.55
0.439863
6.90
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polpc
0.0017868
0.0017666
0.0018358
0.0018859
0.0019244
0.0018952

density
2.307159
2.330254
2.341801
2.346420
2.364896
2.385681
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Data Structures

Data Frames (cont.)
# check dim:
dim(cdata)
## [1] 630

25

# check names:
names(cdata)
## [1] "county"
## [7] "avgsen"
## [13] "pctmin"
## [19] "wmfg"
## [25] "geography"

"year"
"polpc"
"wcon"
"wfed"

"crmrte"
"density"
"wtuc"
"wsta"

"prbarr"
"taxpc"
"wtrd"
"wloc"

"prbconv"
"region"
"wfir"
"mix"

"prbpris"
"smsa"
"wser"
"pctymle"

# compute the mean of the variable 'crime'
mean(cdata$crmrte)
## [1] 0.03158759
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Data Structures

Lists

Lists are a key concept in R
A list is an object that contains one or more objects
The objects contained in a list can be of different types
Lists are produced with the list() function
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Data Structures

Lists (cont.)
Create a data list:
x=c(2,3,4)
y=c("yes","no","no","yes")
z=matrix(1:10,nrow=2)
b=list(x,y,z)
b
##
##
##
##
##
##
##
##
##
##

[[1]]
[1] 2 3 4
[[2]]
[1] "yes" "no"
[[3]]
[1,]
[2,]

"no"

"yes"

[,1] [,2] [,3] [,4] [,5]
1
3
5
7
9
2
4
6
8
10

b[[1]] # print out the first element of the list
## [1] 2 3 4
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Common Commands

Common R commands you will use a lot
seq() - create a sequence of numbers by a specified step length, e.g., seq(0,
1, by = .01) creates a vector [0,.01,.02,.03....99,1]
: - create a sequence of integers from start:end, e.g., -2:2
c() - concatenate objects together, e.g., c(1:5, 6:10)
cbind() - combine two vectors as columns, i.e., side by side, cbind(1:5, 6:10)
rbind() - combine two vectors as rows, i.e., one on top of the other,
rbind(1:5, 6:10)
list() - create a list of elements, e.g., list(1:5, 6:10, list(c(1:5, 6:10)))
library() - load a package, e.g., library(bayes)
!, &, | - logical operators not, and, and or respectively
str() - tells you the structure of an object
summary() - summarize an object
Chen Zhu (CAU)
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Common Commands

Read in a csv file
# Read CSV into R:
MyData <- read.csv(file="c:/TheDataIWantToReadIn.csv", header=TRUE, sep=",")

The above reads the file TheDataIWantToReadIn.csv into a data frame that
it creates called MyData
header=TRUE specifies that this data includes a header row and sep=“,”
specifies that the data is separated by commas
If you have already set a working directory in R you can just list the file, like
this:
MyData <- read.csv(file="TheDataIWantToReadIn.csv", header=TRUE, sep=",")
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Common Commands

Read in a txt file

# Read txt into R:
# sep = "\t" for tab-separated value
df <- read.table ("190707_alcohol_data_GxE.txt", head = T, sep = "\t", quote = "")
str(df)
'data.frame': 7180 obs. of
$ id
$ age
$ eduyear
$ bmi
$ riskpreference

Chen Zhu (CAU)

68 variables:
: int 1 2 3 4 5 6 7 8 9 10 ...
: int 22 22 22 22 22 22 22 22 22 22 ...
: int 16 16 16 16 16 16 16 16 16 16 ...
: num 1.26 1.26 1.26 1.26 1.26 ...
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Graphics in R

Basic Graphics in R

One of the strengths of the R language is graphics
Simple, exploratory graphics are easy to produce in R
Publication quality graphics can be created
Several device drivers are available including:
pdf - Adobe Portable Document Format
png - PNG bitmap device (like .gif but free of software patents)
jpeg -JPEG bitmap
WMF -Windows meta-file (Windows only)
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Graphics in R

Basic Plotting Functions

High-level functions such as plot, hist, boxplot, or pairs that produce an entire
plot or initialize a plot
Low-level functions that add to an existing plot created with a high-level plotting
function. Examples are points, lines, text, axis, etc.
Note: After creating a new plot with a high-level plotting function, you can add
to the plot by making calls to low-level plotting functions
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Graphics in R

Basic Graphics: Examples
# A histogram of 1000 normal random numbers:
set.seed(99)
rv <- rnorm(1000)
hist(rv)

150
100
0

50

Frequency

200

Histogram of rv

−2

0

2

4

rv
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Graphics in R

Basic Graphics: Examples (cont.)
# A histogram of 1000 normal random numbers:
h<-hist(rv, main = "Histogram of 1000 normal random numbers", breaks=12,
col="lightblue")
# Add a Normal Curve
xfit<-seq(min(rv),max(rv),length=40)
yfit<-dnorm(xfit,mean=mean(rv),sd=sd(rv))
yfit <- yfit*diff(h$mids[1:2])*length(rv)
lines(xfit, yfit, col="blue", lwd=2)

150
100
0

50

Frequency

200

Histogram of 1000 normal random numbers
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Graphics in R

Graphics Using ggplot2

# ggplot2 is a plotting system for R, based on the grammar of graphics,
# which tries to take the good parts of base and lattice graphics and
# none of the bad parts.
library(ggplot2)
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Graphics in R

Graphics Using ggplot2 (cont.)
# The mpg dataset contains a subset of the fuel economy data.
# displ. engine displacement, in litres
# hwy. highway miles per gallon
p <- ggplot(mpg, aes(displ, hwy))
p + geom_point()

# Create a plot
# Add points

hwy

40

30

20

2
Chen Zhu (CAU)
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Graphics in R

Graphics Using ggplot2 (cont.)
ggplot(mpg, aes(displ, hwy))+
geom_point()+
geom_line()
# Connect points

hwy

40

30

20

2

3

4

5

6

7

displ
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Graphics in R

Graphics Using ggplot2 (cont.)
# Color the points according to the number of cylinders in the engine:
ggplot(mpg, aes(displ, hwy, color = factor(cyl)))+
geom_point()+
geom_line()

40

hwy

factor(cyl)
4

30

5
6
8
20

2

3

4

5

6

7

displ
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Graphics in R

Graphics Using ggplot2 (cont.)
# Add a loess (locally weighted scatterplot smoothing) line with the
# standard error represented by a semi-transparent ribbon:
ggplot(mpg, aes(displ, hwy))+
geom_point()+
stat_smooth()
## geom_smooth: method="auto" and size of largest group is <1000, so using
loess. Use ’method = x’ to change the smoothing method.

hwy

40

30

20

2
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Graphics in R

Graphics Using ggplot2: Network Diagrams
# A network diagrams with ggplot2:
doInstall <- FALSE
toInstall <- c("sna", "ggplot2", "Hmisc", "reshape2")
if(doInstall){install.packages(toInstall, repos =
"http://cran.r-project.org")}
lapply(toInstall, library, character.only = TRUE)
# Empty ggplot2 theme
new_theme_empty <- theme_bw()
new_theme_empty$line <- element_blank()
new_theme_empty$rect <- element_blank()
new_theme_empty$strip.text <- element_blank()
new_theme_empty$axis.text <- element_blank()
new_theme_empty$plot.title <- element_blank()
new_theme_empty$axis.title <- element_blank()
new_theme_empty$plot.margin <- structure(c(0, 0, -1, -1), unit = "lines",
valid.unit = 3L, class = "unit")
data(coleman) # Load a high school friendship network
adjacencyMatrix <- coleman[1, , ] # Fall semester
layoutCoordinates <- gplot(adjacencyMatrix) # Get layout coordinates
adjacencyList <- melt(adjacencyMatrix) # Convert to list of ties only
adjacencyList <- adjacencyList[adjacencyList$value > 0, ]
Chen Zhu
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Graphics in R

Graphics Using ggplot2: Network Diagrams (cont.)
zp1 <- zp1 + scale_colour_gradient(low = gray(0), high = gray(9/10),
guide = "none")
zp1 <- zp1 + scale_size(range = c(1/10, 1), guide = "none")
zp1 <- zp1 + new_theme_empty # Clean up plot
print(zp1)
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Graphics in R

Graphics Using ggplot2: Choropleth Map
# A choropleth map of US unemployment rates with ggplot2:
rm(list=ls(pat="*"))
# Remove all objects
setwd("C:/Users/Chen Z/Dropbox/Tutorials/T. R/T. ggplot2/map/map")
library(ggplot2)
library(maps)
library(scales)
# First task - get matching state and county variables
# for both datasets. And unfortauntely it's not quite right, as you can
# see from the finish product - some counties are missing.
unemp <- read.csv("unemployment09.csv", header = F, stringsAsFactors = F)
names(unemp) <- c("id", "state_fips", "county_fips", "name", "year",
"?", "?", "?", "rate")
unemp$county <- tolower(gsub(" County, [A-Z]{2}", "", unemp$name))
unemp$state <- gsub("^.*([A-Z]{2}).*$", "\\1", unemp$name)
county_df <- map_data("county")
names(county_df) <- c("long", "lat", "group", "order", "state_name",
"county")
county_df$state <- state.abb[match(county_df$state_name,
tolower(state.name))]
Chen Zhu (CAU)
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Graphics in R

Graphics Using ggplot2: Choropleth Map (cont.)
ggplot(choropleth, aes(long, lat, group = group)) +
geom_polygon(aes(fill = rate_d), colour = alpha("white", 1/2),
size = 0.2) +
geom_polygon(data = state_df, colour = "white", fill = NA) +
scale_fill_brewer(palette = "PuRd")
50

45
rate_d
(0,2]
40

(2,4]

lat

(4,6]
(6,8]

35

(8,10]
(10,35]
30

25
−120
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Graphics in R
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Data Analysis in R

Descriptive Statistics

R has several built-in commands for describing data:
summary
mean
median
min
max
range
sd
cor
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Data Analysis in R

R Data Analysis Examples: Logit Regression

Example: A researcher is interested in how variables, such as GRE (Graduate
Record Exam scores), GPA (grade point average) and prestige of the
undergraduate institution, effect admission into graduate school. The response
variable, admit/don’t admit, is a binary variable.
# Load packages
library(ggplot2)
# Get data
mydata <- read.csv("http://zhuchen.org.cn/wp-content/uploads/2020/03/binary.csv")
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Data Analysis in R

R Data Analysis Examples: Check Data

# View the first few rows of the data
head(mydata)
##
##
##
##
##
##
##

1
2
3
4
5
6

admit
0
1
1
1
0
1

gre
380
660
800
640
520
760

gpa rank
3.61
3
3.67
3
4.00
1
3.19
4
2.93
4
3.00
2
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Data Analysis in R

R Data Analysis Examples: Summary Stats

# Get basic descriptives for the entire data set
summary(mydata)
##
##
##
##
##
##
##

admit
Min.
:0.000
1st Qu.:0.000
Median :0.000
Mean
:0.318
3rd Qu.:1.000
Max.
:1.000

Chen Zhu (CAU)

gre
Min.
:220
1st Qu.:520
Median :580
Mean
:588
3rd Qu.:660
Max.
:800

gpa
Min.
:2.26
1st Qu.:3.13
Median :3.40
Mean
:3.39
3rd Qu.:3.67
Max.
:4.00
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rank
Min.
:1.00
1st Qu.:2.00
Median :2.00
Mean
:2.48
3rd Qu.:3.00
Max.
:4.00
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Data Analysis in R

R Data Analysis Examples: Using The Logit Model

# Convert "rank" to a factor to indicate that it should be treated
# as a categorical variable
mydata$rank <- factor(mydata$rank)
# The code below estimates a logistic regression model using the glm
# (generalized linear model) function
mylogit <- glm(admit ~ gre + gpa + rank, data = mydata,
family = "binomial")

Chen Zhu (CAU)
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Data Analysis in R

summary(mylogit)
##
##
##
##
##
##
##
##
##
##
##
##
##
##
##
##
##
##
##
##
##
##
##
##
##

Call:
glm(formula = admit ~ gre + gpa + rank, family = "binomial",
data = mydata)
Deviance Residuals:
Min
1Q Median
-1.627 -0.866 -0.639

3Q
1.149

Max
2.079

Coefficients:
Estimate Std. Error z value Pr(>|z|)
(Intercept) -3.98998
1.13995
-3.50 0.00047 ***
gre
0.00226
0.00109
2.07 0.03847 *
gpa
0.80404
0.33182
2.42 0.01539 *
rank2
-0.67544
0.31649
-2.13 0.03283 *
rank3
-1.34020
0.34531
-3.88 0.00010 ***
rank4
-1.55146
0.41783
-3.71 0.00020 ***
--Signif. codes: 0 '***' 0.001 '**' 0.01 '*' 0.05 '.' 0.1 ' ' 1
(Dispersion parameter for binomial family taken to be 1)
Null deviance: 499.98
Residual deviance: 458.52
AIC:Chen
470.5
Zhu (CAU)

on 399
on 394

degrees of freedom
degrees of freedom
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Data Analysis in R

R Data Analysis Examples: Confidence Intervals

## CIs using standard errors
confint.default(mylogit)
##
##
##
##
##
##
##

(Intercept)
gre
gpa
rank2
rank3
rank4

2.5 %
-6.2242419
0.0001202
0.1536837
-1.2957513
-2.0169921
-2.3703986

Chen Zhu (CAU)

97.5 %
-1.755716
0.004409
1.454391
-0.055135
-0.663416
-0.732529
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Closing

Closing
R is a very useful and powerful tool for researchers
Learning the syntax can be diffcult at first
However, with some practice, you will find that R is easier to use and a great
program

Chen Zhu (CAU)
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Closing

Other resources

UCLA - Resources to help you learn and use R: https://stats.idre.
ucla.edu/r/seminars/introduction-to-regression-in-r/
DataCamp:
https://www.datacamp.com/courses/free-introduction-to-r
Cyclismo: http://www.cyclismo.org/tutorial/R/index.html

Chen Zhu (CAU)
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